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INTRODUCTION 
 

 

Welcome to forestclimateleaders.org website management guide 
 
Congratulations on your new forestclimateleaders.org website! This guide is designed to help you 
understand how to manage and update your website effectively. Whether you're adding new content, 
customizing the design, or ensuring everything runs smoothly, this guide will provide you with the 
necessary steps and tips to navigate the forestclimateleaders.org website with ease. 

 

Purpose of the Guide 
 
The purpose of this guide is to empower you with the knowledge and skills needed to make changes 
to your website independently. By following the instructions and tips provided, you'll be able to keep 
your website up-to-date, engaging, and secure. 
 

Overview of the Website 
 
Forestclimateleaders.org website is designed to be a dynamic and interactive platform that serves 
your specific needs. From showcasing your services to sharing valuable content, the website has 
been built with flexibility and functionality in mind. This guide will walk you through the main features 
and tools available, ensuring you can make the most out of your website. 
 
 
 
Let's get started on this journey to mastering your forestclimateleaders.org website! 
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2. Enter your username and password. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. After logging in successfully, you will be directed to the dashboard. 
 

  

LOGGING IN 
URL to Access the Admin Panel:  https://forestclimateleaders.org/wp-admin 

Username and Password: The credentials are shared in a separate email. 

Steps to Log In:  

1. Open your browser, such as Chrome or Microsoft Edge, and navigate to the admin panel URL 

 

https://forestclimateleaders.org/wp-admin
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UNDERSTANDING THE DASHBOARD 
The WordPress Dashboard is your command center for managing your website. Upon logging in, 
you'll be greeted with a range of tools and options designed to help you control every aspect of your 
site. Let's break down the key components of the Dashboard and what they do. 
 

Overview of the Dashboard 
 

• The Menu (Left Sidebar): The left sidebar is your main navigation area. It contains links to all 

the administrative functions and settings of your website. Here’s a quick rundown of the main 

menu items: 

o Dashboard: The homepage of your admin area. It provides an at-a-glance overview of 

your site, including site health, activity, and quick links to important areas. 

o Posts: This is where you manage all your blog posts. You can create new posts, edit 

existing ones, and categorize them. 

o Media: The media library is where all your uploaded images, videos, and other media 

files are stored. You can add new files and manage existing ones. 

o Pages: Similar to posts, but for static content like your homepage, about page, and 

contact page. You can create, edit, and manage your site's pages here. 

o Comments: This section allows you to manage comments left by visitors on your posts. 

You can approve, reply, edit, or delete comments. 

o Appearance: Here, you can customize your site’s appearance. This includes managing 

themes, customizing the theme, and managing widgets and menus. 

o Plugins: Manage all your plugins from this section. You can add new plugins, 

activate/deactivate them, and update or delete them. 

o Users: This section allows you to manage all users with access to your site. You can 

add new users, edit user profiles, and assign roles. 

o Tools: Various tools for managing and maintaining your site, including import/export 

options. 

o Settings: This section allows you to configure the basic settings of your site, such as 

site title, email address, time zone, and more. 

 

Common Dashboard Features 
• Toolbar (Top Bar): The toolbar at the top of the screen provides quick access to some of the 

most commonly used functions. Here, you can find shortcuts to view your site, add new 

posts/pages, and access your profile settings. 

• Welcome Widget: This is a quick start guide to help you with the most basic tasks, like 

creating a page or setting up your homepage. You can dismiss this widget once you're 

comfortable with the basics. 

• At a Glance: This section provides a quick overview of the number of posts, pages, 

comments, and the currently active theme. 

• Activity: This widget shows your recent site activity, including recent posts and comments. 
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• Quick Draft: Allows you to quickly write a draft post. It's a good place to jot down ideas for 

future content. 

• Site Health: This tool helps you monitor your site’s performance and security, offering 

suggestions for improvements. 

 

Exploring Further 
Feel free to explore the Dashboard to familiarize yourself with the various options and settings. Each 

menu item often has submenus that offer more specific controls and settings. Don’t worry about 

making mistakes – you can always revert changes or seek help if needed. 

The WordPress Dashboard is designed to be intuitive and user-friendly. With a bit of practice, you'll 

be navigating it like a pro in no time! 

 

 

 

 

 

Before editing the live website, it is highly recommended to take a full 
backup of the website (as explained in the backup section). This 
ensures that you can quickly and easily recover any lost data or 

pages. 
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MANAGING PAGES 
 

• Creating a New Page: 
o Navigate to Pages > Add New. 

 
o Click on “Edit with Elementor”.

 
To make this website easy to edit, I used Elementor. It is very user-friendly and offers 

various elements like text editors, buttons, and tables, which you can easily drag and 

drop as needed. 

After clicking on the Edit with Elementor button you will be redirected to the below page. 

 
o How to add and format layout, text, images, and other media. 

▪ Click on the “+” button located on the right panel. 
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▪ After clicking, you will be prompted to choose a layout. I suggest selecting the 

Flexbox option. 

 
▪ Then, you can choose your desired layout structure. 

 
▪ Now, you will have the layout ready for editing. You can add text, images, media, 

and more from the Elementor panel on the left pane. 

 
▪ Click on the "+" button located inside the newly added layout and choose from 

the elements list on the left panel to make the desired changes to the page. 

▪ For this example, we will change the layout width and margins, add text and an 

image, then edit them by changing the size, background, font, and color. The 

steps to follow are shown in the images below (Highlighted in red are the 

attributes that have been changed). From the Elementor panel, you can search 

or scroll to find the desired element for the page. 
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As shown above, we right-clicked on the layout controls to open the menu and 
selected "Edit Container." 

                
In the Layout tab, change the width unit to "%" and set the value to 100. This will 

make the layout cover 100% of the page width. You can adjust the height in a 

similar manner, choosing from units like pixels, centimeters, inches, and more. and 

change the direction to left to right. 

In the Advanced tab, uncheck the "Link Values Together"  option and set the top 

margin to 9%. 

 

 
Click on the “+” button and drag and drop the text editor element from the Elementor 

panel to the layout. 
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In the Content tab, you can add and format the text. 

 
In the Style tab, you can change the text color, Typography (fonts, size), text 

shadow and the alignment. Change the text to white. 

In the Advance tab, you can change the margin, padding, text editor width and 

more. change the width to 50% and scroll down and change background color. 
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Right-click on the layout, and you'll see options on the left to choose an element 

from the list. Drag and drop the image element to the right of the text editor. As you 

move the image, you'll notice a pink-colored area indicating where it will be placed. 

Release the image in that area. 

 
Click on the image element, and you'll see options on the left side where you can 

modify the image and adjust other properties, similar to the text editor described 

earlier. 

   
In the Media Library, you can either select from pre-uploaded media or upload new 

files by using the Upload Files tab. 

 
Our new page is ready. You can go ahead and publish it, then view the results. 
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▪ To add a new layout, click the “+” button below the current layout. Alternatively, 

you can duplicate the existing layout by right-clicking on the top of the layout, 

selecting "Duplicate," and then adjusting the content as needed. 

                                                          or  

• Editing an Existing Page: 
o Navigate to Pages > All Pages.   

   
o Select the page to edit. 

 
o Make the necessary changes as outlined in the "Adding New Page and Updating 

Content" sections. 

o Save and update/publish the changes. 

• Deleting a Page: 
o Navigate to Pages > All Pages. 

 
o Select the page to delete or click on the “Trash” link. 

o Move to Trash and confirm deletion. 
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UPDATING CONTENT 
Keeping your website content fresh and up-to-date is crucial for engaging your audience and 
maintaining the relevance of your site. In this section, we'll cover how to update text, images, and 
other media on forestclimateleaders.org website. 
 

• Updating Text Content 
 

1. Editing Existing Text: 
o Navigate to the Page: Go to the left sidebar and select Pages, depending on 

where you want to make changes. 
o Select the Item to Edit: Click on the Edit with Elementor link under the page you 

wish to update. This will open the editor interface. 
o Make Your Changes: You can now edit the text directly in the editor. You’ll see 

different blocks for each section of content.  
o Save or Update: Once you’ve made your changes, click the Update button on the 

bottom-left side of the screen to save your changes. 
2. Formatting Text: 

o Text editor: You can format your text as needed using the Content tab and the text 
area. 

 

o Preview Changes: Before saving, use the  button to see how your changes will 
look on the live site. 

 

• Updating Images and Media 
• Replacing Existing Images: 

o Navigate to the Media Library: Go to Media > Library in the left sidebar. 

 
o Select the Image: Click on the image you want to replace. You’ll see an option to 

Replace Media (this option might require a plugin if not available by default). 
o Upload New Image: Follow the prompts to upload a new image file to replace the 

existing one. 

• Adding New Media: 
o Add New Files: Go to Media > Add New. You can drag and drop files or click the 

Select Files button to upload new images, videos, or documents. 
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o Insert Media into Pages/Posts: While editing a page or post, click the Add Media 
button above the editor. Select the media file from your library or upload a new one. 
You can then adjust its alignment and size before inserting it into your content. 

• Managing Media Files: 
o Edit Media: Click on any media file in the library to access its details. You can edit 

the file’s title, caption, alt text, and description. 
o Delete Media: To delete an item, select it in the media library and click Delete 

Permanently. Be cautious, as this will remove the file from the site entirely. 
 

• Embedding Media 
 

1. Videos and Audio: 
o Embed Directly: To embed videos or audio files from platforms like YouTube or Vimeo, 

simply paste the URL directly into the editor. WordPress will automatically convert it into 
an embedded player. 

o Use the Embed Block: In the Elementor editor, you can use video element to embed 
your videos. 

o           
2. Other Media Types: 

o Embed Documents: For PDFs and other documents, you may need a plugin to 
provide an embed option or simply link to the file. 
 

Final Steps 
 

• Review Your Changes: After updating text or media, always preview your changes to ensure 

everything looks as expected. 

• Save and Publish: Once you’re satisfied with the updates, click Publish to make your 

changes live. 
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MANAGING PLUGINS 
Plugins are powerful tools that extend the functionality of your WordPress site, allowing you to add 
features, enhance performance, and improve security. This section will guide you through managing 
your plugins, including installing, updating, and configuring them. 
 

Installing Plugins 
1. Navigate to the Plugins Page: 

o Go to Plugins > Add New in the left sidebar of the WordPress admin panel. 

 
2. Search for a Plugin: 

o Use the search bar to find the plugin you need. You can search by plugin name or 
keywords related to the functionality you're looking for. 

3. Install the Plugin: 
o Once you find the desired plugin, click the Install Now button next to it. The installation 

process will begin. 
4. Activate the Plugin: 

o After installation, the button will change to Activate. Click it to enable the plugin on your 
site. 

Updating Plugins 
1. Check for Updates: 

o Go to Plugins > Installed Plugins. If updates are available, you will see a notification 
above the list of plugins. 

2. Update Plugins: 
o Click the Update Now link under the plugin that needs updating. WordPress will handle 

the update process automatically. 
3. Bulk Updates: 

o If multiple plugins need updating, you can select them by checking the boxes next to 
their names, then use the Bulk Actions dropdown menu to choose Update and click 
Apply. 

Deactivating and Deleting Plugins 
1. Deactivate a Plugin: 

o Go to Plugins > Installed Plugins. Find the plugin you wish to deactivate and click the 
Deactivate link beneath it. This will disable the plugin but keep it installed. 

2. Delete a Plugin: 
o After deactivating a plugin, the Delete link will appear. Click Delete to remove the 

plugin from your site entirely. Confirm the deletion when prompted. 

Configuring Plugins 
1. Access Plugin Settings: 

o Some plugins have their own settings pages. To access these, go to Settings in the left 
sidebar or find a menu item specific to the plugin you installed. 

2. Configure Plugin Options: 
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o Follow the plugin’s documentation or on-screen instructions to adjust settings according 
to your needs. Each plugin will have its own configuration options, so refer to the 
plugin’s support resources for detailed guidance. 

Plugin Best Practices 
• Regular Updates: Keep your plugins up-to-date to ensure compatibility with the latest 

WordPress version and to benefit from security and performance improvements. 
• Review and Test: Before installing a new plugin, review its ratings, reviews, and compatibility 

with your WordPress version. Test new plugins on a staging site, if possible, to avoid potential 
conflicts. 

• Manage Plugin Conflicts: Occasionally, plugins may conflict with each other or with your 
theme. If you experience issues, deactivate all plugins and reactivate them one by one to 
identify the problem. 

Troubleshooting 
• Plugin Issues: If you encounter issues after installing or updating a plugin, try deactivating it 

to see if the problem resolves. Consult the plugin’s support forum or documentation for 
additional help. 

 
 
 

 

CREATING AND MANAGING MENUS 
Menus are essential for organizing and displaying your website’s navigation links, helping users find 
important pages and sections quickly. In this section, we'll walk you through the process of creating, 
managing, and customizing menus in WordPress. 
 

Creating a New Menu 
1. Navigate to Menus: 

o Go to Appearance > Menus in the left sidebar of the WordPress admin panel. 

 
2. Create a New Menu: 

o Click the Create a New Menu link at the top of the page. 
o Enter a name for your menu in the Menu Name field (e.g., “Main Menu”). 
o Click Create Menu to add the new menu to your site. 

3. Add Items to Your Menu: 
o On the left side, you'll see several boxes, including Pages, Custom Links, and 

Categories. 
o Check the boxes next to the items you want to add and click Add to Menu. You can 

add pages, posts, categories, and custom links to your menu. 
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o Arrange the menu items by dragging and dropping them into place. You can create sub-

menus by dragging items slightly to the right under other items. 
4. Save Your Menu: 

o Click the Save Menu button to store your changes. 

Assigning Menus to Locations 
1. Select Menu Locations: 

o In the Menu Settings section, you'll see Display location options. These locations 
correspond to different areas of your site where the menu can appear (e.g., Primary 
Menu, Footer Menu). 

o Check the box for the location where you want the menu to be displayed. 
2. Save Changes: 

o Click the Save Menu button again to apply your menu to the selected locations. 

Editing an Existing Menu 
1. Access Menu Settings: 

o Go to Appearance > Menus and select the menu you want to edit from the dropdown 
list. 

2. Modify Menu Items: 
o To change the name or URL of an existing menu item, click the down arrow next to the 

item to expand its settings. Make your changes and click Save Menu. 
3. Rearrange Menu Items: 

o Drag and drop menu items to reorder them. You can also create nested sub-menus by 
positioning items under other items. 

4. Remove Menu Items: 
o Click the down arrow next to the menu item you want to remove, then click Remove. 

Click Save Menu to apply the changes. 

Customizing Menus 
1. Add Custom Links: 

o In the Custom Links box on the left, enter the URL and link text for custom links. Click 
Add to Menu to include them in your menu. 

2. Create Drop-Down Menus: 
o To create a drop-down menu, simply drag menu items slightly to the right under a 

parent item. This will create a hierarchical structure with sub-menus. 
3. Edit Menu Labels and Titles: 

o Click the down arrow next to any menu item to change its label (what users see) or its 
title attribute (additional information shown on hover). 
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USER MANAGEMENT 
Managing users effectively is crucial for maintaining the security and organization of your WordPress 
site. Whether you’re adding new users, updating user roles, or removing users, this section will guide 
you through the essential steps for user management. 
 

Adding New Users 
 

1. Navigate to User Management: 
o Go to Users > Add New in the left sidebar of the WordPress admin panel. 

 
2. Enter User Information: 

o Username: Choose a unique username for the new user. 
o Email: Enter a valid email address. The user will receive a notification with login details. 
o First Name and Last Name: Optional fields for user details. 
o Website: Optional field to add the user’s website URL. 
o Password: Generate a strong password or create one manually. Users will be 

prompted to change their password upon first login if you use the “Send User 
Notification” option. 

o Role: Select the user’s role from the dropdown menu. The available roles are: 
▪ Subscriber: Can manage their own profile and read content. 
▪ Contributor: Can write and manage their own posts but cannot publish. 
▪ Author: Can publish and manage their own posts. 
▪ Editor: Can manage and publish posts of all users and manage comments. 
▪ Administrator: Has full access to all administrative features. 

3. Add User: 
o Click the Add New User button to create the new user account. They will receive an 

email with their login credentials if the notification option was selected. 

Editing User Profiles 
1. Access User Profiles: 

o Go to Users > All Users and click on the user’s username you want to edit. 

 
2. Update User Information: 

o You can update the user’s username, email, name, website, and role from the profile 
page. 

o Change Password: To update the password, scroll to the Account Management 
section and enter a new password. 

3. Save Changes: 
o Click the Update User button to save any changes made to the user’s profile. 
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Managing User Roles 
 

1. Edit User Roles: 
o Go to Users > All Users and click Edit under the user’s name. 

 
o In the Role dropdown, select a new role for the user. 

2. Save Changes: 
o Click Update User to apply the new role and permissions. 

 

Removing Users 
 

1. Delete a User: 
o Go to Users > All Users and click Delete under the user’s name. 

 
o You’ll be prompted to confirm the deletion. If the user has content, you can choose to 

attribute their posts to another user or delete them along with the user account. 
2. Reassign Content (if applicable): 

o If the user has posts or pages, you will be asked to reassign their content to another 
user before completing the deletion. 
 

User Management Best Practices 
 

• Role Assignment: Assign roles based on the user’s responsibilities. Avoid giving 
unnecessary permissions to limit security risks. 

• Regular Reviews: Periodically review user accounts and roles to ensure that access levels 
are up-to-date and relevant. 

• Password Security: Encourage users to use strong passwords and consider enabling two-
factor authentication for added security. 
 

Troubleshooting 
• Access Issues: If a user reports access issues, verify their role and permissions. Ensure they 

are using the correct username and password. 
• Content Reassignment: If deleting a user with content, ensure that content is reassigned 

appropriately to avoid losing important data. 
 

By effectively managing users and their roles, you can ensure forestclimateleaders.org site remains 
secure and well-organized, providing a smooth experience for both administrators and site visitors. 
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BACKUP AND RESTORE 
UpdraftPlus is a reliable WordPress plugin for backing up and restoring your website. I have 
installed it already, here's a brief guide on how to use it: 
 

1. Install and Activate UpdraftPlus (if deleted accidently): 
o Go to Plugins > Add New, search for UpdraftPlus, and click Install Now. Once 

installed, click Activate. 
2. Configure Backup Settings: 

o Navigate to Settings > UpdraftPlus Backups.  

 
o Set your backup schedule, choose remote storage options (like Google Drive or 

Dropbox), and configure email notifications. 

 
3. Perform a Backup: 

o In the UpdraftPlus Backups settings page, click Backup Now. Select the components 
you want to back up (files, database) and click Backup Now to start the process. 

 
o Once the backup is complete, download all the backup components and store them on 

a secure drive or device
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4. Restore from a Backup: 
o Go to Settings > UpdraftPlus Backups and select the Existing Backups tab or 

upload from your computer. Choose the backup you wish to restore, and click Restore. 
Follow the prompts to restore your files and database.  
 

 
 

 
 
 
 
 
 
 
 

TROUBLESHOOTING 
 
Occasionally, you might encounter issues with your WordPress website. Here are some common 
problems and their solutions: 
 
1. Website is Down 

• Check Hosting Status: Ensure that the issue isn’t related to your hosting provider. 

Sometimes, server outages or maintenance can cause temporary downtime. 

• Contact DreamHost Support: If your website is down and you suspect a hosting issue, 

contact DreamHost customer support. They can provide assistance and information on any 

ongoing server problems. You can reach DreamHost support by visiting their website. 

2. Login Issues 

• Forgotten Password: Use the “Lost your password?” link on the login page to reset your 

password via email. 

• Browser Cache: Clear your browser cache and cookies, then try logging in again. 

• Plugin Conflict: Disable all plugins via FTP or your hosting control panel to see if a plugin is 

causing the issue. 

3. Content Not Updating 

• Clear Caches: Clear your browser cache and any site caches if you’re using a caching plugin. 

• Check for Plugin Conflicts: Disable caching or other plugins to see if they’re affecting 

content updates. 

 


